vSphere Client auf DC installieren

Problem

Der vmware vSphere Client ab Version 5.1u1 lässt sich nicht mehr freiwillig auf einem Domänencontroller installieren. Versucht man das, erhält man folgende Ferhlermeldung:

“vSphere Client erfordert Windows XP XP2 oder höher. vSphere Client kann auf dem Domänencontroller nicht installiert.”

vsphere-client-auf-dc-installieren

Lösung

Aufgrund der Microsoft-Vorgabe “Always Isolate DC Role”, der auch grundsätzliche zuzustimmen ist, hat vmWare den OS-Check in den MSI-Wrapper eingebaut. Selbstverständlich lässt sich das (auf eigene Gefahr) auch umgehen. Der Client läuft auch stressfrei auf einem DC.

  • Plattform-Installer (~100mb) aus dem Globalen Installert (~350MB) befreien. Dazu einfach das Paket ganz normal aufrufen un den “viclient-setup.exe” aus %temp%\{langeinummer} wegkopieren. Danach den Installer nach der Fehlermeldung wieder schliessen.
  • Den Installer aufrufen mit: viclient-setup.exe /VSKIP_OS_CHECKS=”1″

Update: Ein vmware Engineer sagt zu diesem Installer folgendes (Zitat):

We did this deliberately to enforce a Microsoft standard that our guys agree with – don’t install software on a DC, but they made that decision in isolation. Nothing more than that.  So use the workaround safely and hopefully we can undo this in the future.

Quelle: Ugg.li

Advertisements

2 Kommentare

Eingeordnet unter Microsoft, VMware

2 Antworten zu “vSphere Client auf DC installieren

  1. Ulrich

    Hat leider bei mir (vSphere Client 5.5) nicht mehr funktioniert, den Parameter hat er mir einfach ignoriert. Nach verzweifelter Suche bin ich auf eine Lösung gekommen:

    1.) Installer extrahieren wie beschrieben.
    2.) Extrahierten Installer starten, nach Start (und vor dem wegklicken der Fehlermeldung) das Verzeichnis mit dem MSI-File in %temp% wegkopieren.
    3.) Aus dem „redist“-Verzeichnis die vjredist64.exe installieren (bei x64-OS).
    4.) Die extrahierte MSI-Datei mit InstEd It! (Freeware) editieren, links nach „LaunchConditions“ suchen und die Zeile mit der Fehlermeldung löschen. MSI speichern und installieren.

    So hat es bei mir endlich funktioniert, ich hoffe das hilft jemandem, der das selbe Problem hat.

    Gefällt mir

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s